Debian セキュリティ勧告

DSA-2069-1 znc -- サービス拒否攻撃

報告日時:
2010-07-11
影響を受けるパッケージ:
znc
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 584929.
Mitre の CVE 辞書: CVE-2010-2448.
詳細:

IRC バウンサの ZNC に、認証されていないコネクションがある条件でトラ フィック統計情報を要求した場合に NULL ポインタ参照を起こす欠陥があり、 サービス拒否攻撃が可能です。

安定版 (stable) ディストリビューション (lenny) では、この問題はバー ジョン 0.058-2+lenny4 で修正されています。

テスト版 (squeeze) および不安定版 (unstable) ディストリビューション では、この問題はバージョン 0.090-2 で修正されています。

直ぐに znc パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4.dsc
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4.diff.gz
http://security.debian.org/pool/updates/main/z/znc/znc_0.058.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny4_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。