Bulletin d'alerte Debian

DSA-2073-1 mlmmj -- Vérification d'entrée manquante

Date du rapport :
20 juillet 2010
Paquets concernés :
mlmmj
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2009-4896.
Plus de précisions :

Florian Streibelt a signalé un défaut de traversée de répertoire dans la façon dont le gestionnaire de liste de diffusion Mailing List Managing Made Joyful traite les requêtes d'utilisateurs venant de l'interface web d'administration sans vérification d'entrée suffisante. Un attaquant distant et authentifié pourrait utiliser ces défauts pour lire et effacer des fichiers arbitraires.

Pour la distribution stable (Lenny), ces problèmes ont été corrigés dans la version 1.2.15-1.1+lenny1.

Pour la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 1.2.17-1.1.

Nous vous recommandons de mettre à jour votre paquet mlmmj.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1.dsc
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj-php-web_1.2.15-1.1+lenny1_all.deb
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj-php-web-admin_1.2.15-1.1+lenny1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/m/mlmmj/mlmmj_1.2.15-1.1+lenny1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.