Debians sikkerhedsbulletin

DSA-2083-1 moin -- manglende fornuftighedskontrol af inddata

Rapporteret den:
2. aug 2010
Berørte pakker:
moin
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 584809.
I Mitres CVE-ordbog: CVE-2010-2487.
Yderligere oplysninger:

Man opdagede at moin, en python-klon af WikiWiki, ikke på tilstrækkelig vis fornuftighedskontrollerer parametre, når de overføres til funktionen add_msg. Dermed var det muligt for en fjernangriber at udføre på tværs af websteder (XSS), for eksempel gennem skabelonparameteret.

I den stabile distribution (lenny), er dette problem rettet i version 1.7.1-3+lenny5.

I distributionen testing (squeeze), vil dette problem snart blive rettet.

I den ustabile distribution (sid), er dette problem rettet i version 1.9.3-1.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1-3+lenny5.dsc
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1.orig.tar.gz
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1-3+lenny5.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/m/moin/python-moinmoin_1.7.1-3+lenny5_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.