Debian Security Advisory

DSA-2087-1 cabextract -- programming error

Date Reported:
04 Aug 2010
Affected Packages:
cabextract
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2010-2801.
More information:

It was discovered that a programming error in the archive test mode of cabextract, a program to extract Microsoft Cabinet files, could lead to the execution of arbitrary code.

For the stable distribution (lenny), this problem has been fixed in version 1.2-3+lenny1.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your cabextract package.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Source:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1.diff.gz
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1.dsc
Alpha:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_armel.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cabextract/cabextract_1.2-3+lenny1_sparc.deb

MD5 checksums of the listed files are available in the original advisory.