Bulletin d'alerte Debian

DSA-2107-1 couchdb -- Chemin de recherche non fiable

Date du rapport :
9 septembre 2010
Paquets concernés :
couchdb
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 594412.
Dans le dictionnaire CVE du Mitre : CVE-2010-2953.
Plus de précisions :

Dan Rosenberg a découvert que dans couchDB, une base de données orientées document tolérante aux erreurs et sans schéma, un chemin de recherche de bibliothèque non sécurisé est utilisé. Un attaquant local pourrait exécuter du code arbitraire en commençant par déposer une bibliothèque partagée contrefaite de façon malveillante dans un répertoire, puis en faisant exécuter couchDB par un administrateur depuis ce même répertoire.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 0.8.0-2+lenny1.

Nous vous recommandons de mettre à jour votre paquet couchdb.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1.dsc
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1.diff.gz
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/couchdb/couchdb_0.8.0-2+lenny1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.