Debian セキュリティ勧告

DSA-2114-1 git-core -- バッファオーバフロー

報告日時:
2010-09-26
影響を受けるパッケージ:
git-core
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 595728, バグ 590026.
Mitre の CVE 辞書: CVE-2010-2542.
詳細:

The Debian 安定版ポイントリリース 5.0.6 には、レビジョン管理システム Git のセキュリティ更新版が収録されていました。残念ながら、この更新にはバグが あり、Git レポジトリのコピーや作成ができなくなっていました。この更新では、 その問題を修正します。この問題は Debian バグ #595728 として登録されてい ます。

元々直そうとしていた修正は、細工したワーキングディレクトリでローカルユー ザに git コマンドを実行させることにより、任意のコードが実行可能であると いうものです (CVE-2010-2542)。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 1.5.6.5-3+lenny3.2 で修正されています。

hppa アーキテクチャ向けのパッケージは今回の更新に含まれていません。但し、 hppa アーキテクチャでのこのバグの攻撃方法は知られていません。

テスト版 (testing) および不安定版 (unstable) では、このセキュリティ問題は バージョン 1.7.1-1.1 で修正されています。これらのディストリビューションで は、今回のバグの作り込みの影響はありません。

直ぐに git-core パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2.dsc
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5.orig.tar.gz
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/g/git-core/git-cvs_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-gui_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-arch_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-daemon-run_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/gitweb_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-svn_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-doc_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/git-email_1.5.6.5-3+lenny3.2_all.deb
http://security.debian.org/pool/updates/main/g/git-core/gitk_1.5.6.5-3+lenny3.2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_armel.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/g/git-core/git-core_1.5.6.5-3+lenny3.2_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。