Debian Security Advisory

DSA-2116-1 freetype -- integer overflow

Date Reported:
04 Oct 2010
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2010-3311.
More information:

Marc Schoenefeld has found an input stream position error in the way the FreeType font rendering engine processed input file streams. If a user loaded a specially-crafted font file with an application linked against FreeType and relevant font glyphs were subsequently rendered with the X FreeType library (libXft), it could cause the application to crash or, possibly execute arbitrary code.

After the upgrade, all running applications and services that use libfreetype6 should be restarted. In most cases, logging out and in again should be enough. The script checkrestart from the debian-goodies package or lsof may help to find out which processes are still using the old version of libfreetype6.

For the stable distribution (lenny), these problems have been fixed in version 2.3.7-2+lenny4.

The testing distribution (squeeze) and the unstable distribution (sid) are not affected by this problem.

We recommend that you upgrade your freetype packages.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.