Säkerhetsbulletin från Debian

DSA-2121-1 typo3-src -- flera sårbarheter

Rapporterat den:
2010-10-19
Berörda paket:
typo3-src
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2010-3714, CVE-2010-3715, CVE-2010-3716, CVE-2010-3717.
Ytterligare information:

Flera utifrån nåbara sårbarheter har upptäckts i TYPO3. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2010-3714

    Flera utifrån nåbara filläckor jumpUrl-mekanismen och utökningshanteraren tillät angripare att läsa filer med rättigheter som kontot under vilket webbservern körde.

  • CVE-2010-3715

    TYPO3:s bakända innehöll flera serveröverskridande skriptningssårbarheter och funktionen RemoveXSS filtrerade inte all Javascript-kod.

  • CVE-2010-3716

    Illvilliga editorer med rättighet att skapa användare kunde utöka sina rättigheter genom att skapa nya användare i godtyckliga grupper, pga en avsaknad av kontroll av indata i uppgiftscentret.

  • CVE-2010-3717

    TYPO3 synliggjorde en krasch i PHP:s funktion filter_var, vilket tillät angripare att krascha webbserverprocessen och på så sätt förbruka ytterligare systemresurser.

För den stabila utgåvan (Lenny) har dessa problem rättats i version 4.2.5-1+lenny6.

För den instabila utgåvan (Sid) och uttestningsutgåvan (Squeeze) har dessa problem rättats i version 4.3.7-1.

Vi rekommenderar att ni uppgraderar era TYPO3-paket.

Rättat i:

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.2.5.orig.tar.gz
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.2.5-1+lenny6.dsc
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.2.5-1+lenny6.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src-4.2_4.2.5-1+lenny6_all.deb
http://security.debian.org/pool/updates/main/t/typo3-src/typo3_4.2.5-1+lenny6_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.