Debian Security Advisory

DSA-2135-1 xpdf -- several vulnerabilities

Date Reported:
21 Dec 2010
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2010-3702, CVE-2010-3704.
More information:

Joel Voss of Leviathan Security Group discovered two vulnerabilities in xpdf rendering engine, which may lead to the execution of arbitrary code if a malformed PDF file is opened.

For the stable distribution (lenny), these problems have been fixed in version 3.02-1.4+lenny3.

For the upcoming stable distribution (squeeze) and the unstable distribution (sid), these problems don't apply, since xpdf has been patched to use the Poppler PDF library.

We recommend that you upgrade your poppler packages.