Debian セキュリティ勧告

DSA-2145-1 libsmi -- バッファオーバフロー

報告日時:
2011-01-16
影響を受けるパッケージ:
libsmi
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2010-2891.
詳細:

Andres Lopez Luksenberg さんにより、SMI MIB データをアクセスす るライブラリ libsmi の OID パーザにバッファオーバフローが発見さ れました。

安定版 (stable) ディストリビューション (lenny) では、この問題は バージョン 0.4.7+dfsg-0.2 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題はバージ ョン 0.4.8+dfsg2-3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題 はバージョン 0.4.8+dfsg2-3 で修正されています。

直ぐに libsmi パッケージをアップグレードすることを勧めます。

Debian Security Advisories に関する説明、これらの更新をシステム に適用する方法、FAQ などは http://www.debian.org/security/ を参 照ください。