Debian セキュリティ勧告

DSA-2164-1 shadow -- 入力の不十分なサニタイズ

報告日時:
2011-02-16
影響を受けるパッケージ:
shadow
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-0721.
詳細:

Kees Cook さんにより、chfn および chsh ユーティリティが改行を含むユー ザ入力を適切にサニタイズしていないことが発見されました。攻撃者はこの 欠陥を悪用してパスワードエントリの破壊が可能で、さらに NIS 環境ではユ ーザやグループの作成が可能です。

旧安定版 (lenny) のパッケージはこの問題の影響を受けません。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1:4.1.4.2+svn3283-2+squeeze1 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューションで は、この問題は近く修正予定です。

直ぐに shadow パッケージをアップグレードすることを勧めます。