Bulletin d'alerte Debian

DSA-2177-1 pywebdav -- Injection SQL

Date du rapport :
2 mars 2011
Paquets concernés :
pywebdav
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2011-0432.
Plus de précisions :

On a découvert que PyWebDAV, une implémentation de serveur WebDAV, contient plusieurs vulnérabilités d'injection SQL dans le traitement des droits d'utilisateurs.

La distribution oldstable (Lenny) ne contient pas de paquet python-webdav.

Pour la distribution stable (Squeeze), ce problème a été corrigé dans la version 0.9.4-1+squeeze1.

Pour la distribution testing (Wheezy) et la distribution unstable (Sid), ce problème a été corrigé dans la version 0.9.4-3.

Nous vous recommandons de mettre à jour vos paquets python-webdav.