Debian セキュリティ勧告

DSA-2177-1 pywebdav -- SQL インジェクション

報告日時:
2011-03-02
影響を受けるパッケージ:
pywebdav
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-0432.
詳細:

WebDAV サーバ実装 PyWebDAV に、ユーザのク レデンシャル処理での複数の SQL インジェクションを許す欠陥が発見されま した。

旧安定版 (lenny) には python-webdav パッケージは収録されていません。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 0.9.4-1+squeeze1 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューション では、この問題はバージョン 0.9.4-3 で修正されています。

直ぐに python-webdav パッケージをアップグレードすることを勧めます。