Bulletin d'alerte Debian

DSA-2183-1 nbd -- Débordement de mémoire tampon

Date du rapport :
4 mars 2011
Paquets concernés :
nbd
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2011-0530.
Plus de précisions :

Une régression de débordement de mémoire tampon a été découverte (CVE-2005-3534) dans NBD, le serveur de périphériques blocs en réseau. Cela pourrait mener à l'exécution de code arbitraire sur un serveur NBD à l'aide d'une grande requête.

Pour la distribution oldstable (Lenny), ce problème a été corrigé dans la version 1:2.9.11-3lenny1.

La distribution stable (Squeeze), la distribution testing (Wheezy) et la distribution unstable (Sid) ne sont pas concernées. Ce problème a été corrigé avant la publication de Squeeze dans la version 1:2.9.16-8.

Nous vous recommandons de mettre à jour vos paquets nbd.