Debian セキュリティ勧告

DSA-2187-1 icedove -- 複数の脆弱性

報告日時:
2011-03-09
影響を受けるパッケージ:
icedove
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2010-1585, CVE-2011-0051, CVE-2011-0053, CVE-2011-0054, CVE-2011-0055, CVE-2011-0056, CVE-2011-0057, CVE-2011-0059.
詳細:

Thunderbird の商標非利用版 icedove メール/ニュースクライアントに、複数の 問題が発見されました。

  • CVE-2010-1585

    Roberto Suggi Liverani さんにより、ParanoidFragmentSink で行っているサ ニタイズが不完全であることが発見されました。

  • CVE-2011-0051

    Zach Hoffmann さんにより、eval() を再帰的に呼び出す処理のパーザのバグ のため、攻撃者から確認ダイアログを無理矢理了解させることができること が発見されました。

  • CVE-2011-0053

    レイアウトエンジンのクラッシュのため、任意のコードの実行が行える可能性 があります。

  • CVE-2011-0054, CVE-2010-0056

    Christian Holler さんにより、JavaScript エンジンのバッファオーバフロー のため、任意のコードの実行を許すことが発見されました。

  • CVE-2011-0055

    regenrecht さんと Igor Bukanov さんにより、JSON 実装にメモリの解放後 の使用箇所があり、任意のコードの実行を許すことが発見されました。

  • CVE-2011-0057

    Daniel Kozlowski さんにより、web ワーカ実装の誤ったメモリの処理のため、 任意のコードの実行を許すことが発見されました。

  • CVE-2011-0059

    Peleus Uhley さんにより、プラグインコードにクロスサイトリクエストフォ ージェリの危険性が発見されました。

旧安定版 Lenny のリリースノート記載の通り、旧安定版の Icedove のセキュ リティサポートは通常の Lenny のセキュリティメンテナンス期間の前に打ち切 らざるを得ませんでした。安定版 (stable) に更新するか、他のメールクライ アントに移行してください。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージ ョン 3.0.11-1+squeeze1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ ョン 3.0.11-2 で修正されています。

直ぐに icedove パッケージをアップグレードすることを勧めます。