Рекомендация Debian по безопасности

DSA-2190-1 wordpress -- несколько уязвимостей

Дата сообщения:
11.03.2011
Затронутые пакеты:
wordpress
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2011-0700, CVE-2011-0701.
Более подробная информация:

Две XSS-ошибки и одна потенциальная проблема с раскрытием информации были обнаружены в WordPress, менеджере блога. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2011-0700

    Входные данные, переданные через заголовок сообщения в момент выполнения действий Quick Edit или Bulk Edit, а также через параметры post_status, comment_status и ping_status, неправильно очищаются до момента их использования. Определённые входные данные, переданные через теги в метаполе тегов, очищаются неправильно до их возврата пользователю.

  • CVE-2011-0701

    WordPress некорректно устанавливает пользовательские ограничения доступа при обращении к сообщениям через загрузчик медиа, что может использоваться для раскрытия содержимого, например, закрытых или черновых сообщений.

Предыдущий стабильный выпуск (lenny) не подвержен этим проблемам.

В стабильном выпуске (squeeze) эти проблемы были исправлены в версии 3.0.5+dfsg-0+squeeze1.

В тестируемом (wheezy) и нестабильном (sid) выпусках эти проблемы были исправлены в версии 3.0.5+dfsg-1.

Рекомендуется обновить пакеты wordpress.