Debian Security Advisory

DSA-2192-1 chromium-browser -- several vulnerabilities

Date Reported:
15 Mar 2011
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2011-0779, CVE-2011-1290.
More information:

Several vulnerabilities were discovered in the Chromium browser. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2011-0779

    Google Chrome before 9.0.597.84 does not properly handle a missing key in an extension, which allows remote attackers to cause a denial of service (application crash) via a crafted extension.

  • CVE-2011-1290

    Integer overflow in WebKit allows remote attackers to execute arbitrary code via unknown vectors, as demonstrated by Vincenzo Iozzo, Willem Pinckaers, and Ralf-Philipp Weinmann during a Pwn2Own competition at CanSecWest 2011.

For the stable distribution (squeeze), these problems have been fixed in version 6.0.472.63~r59945-5+squeeze4.

For the testing distribution (wheezy), these problems will be fixed soon.

For the unstable distribution (sid), these problems have been fixed in version 10.0.648.133~r77742-1.

We recommend that you upgrade your chromium-browser packages.