Bulletin d'alerte Debian

DSA-2193-1 libcgroup -- Plusieurs vulnérabilités

Date du rapport :
16 mars 2011
Paquets concernés :
libcgroup
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 615987.
Dans le dictionnaire CVE du Mitre : CVE-2011-1006, CVE-2011-1022.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans libcgroup, une bibliothèque pour contrôler et surveiller les groupes de contrôle :

  • CVE-2011-1006

    Un débordement de tampon basé sur le tas en convertissant une liste de contrôleurs pour une tâche donnée en tableau de chaînes pourrait permettre à un attaquant local d'augmenter ses droits.

  • CVE-2011-1022

    libcgroup ne vérifiait pas correctement l'origine des messages Netlink, autorisant un attaquant local à envoyer des messages Netlink contrefaits pouvant permettre une augmentation de droits.

La distribution oldstable (Lenny) ne contient pas de paquets libcgroup.

Pour la distribution stable (Squeeze), ce problème a été corrigé dans la version 0.36.2-3+squeeze1.

Pour la distribution testing (Wheezy) et la distribution unstable (Sid), ce problème sera corrigé prochainement.

Nous vous recommandons de mettre à jour vos paquets libcgroup.