Рекомендация Debian по безопасности

DSA-2201-1 wireshark -- несколько уязвимостей

Дата сообщения:
23.03.2011
Затронутые пакеты:
wireshark
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2011-0538, CVE-2011-0713, CVE-2011-1139, CVE-2011-1140, CVE-2011-1141.
Более подробная информация:

Хузаифа Сидхпурвала, Йорнхен и Сяопэн Чжан обнаружили несколько уязвимостей в Wireshark, программе для анализа сетевого трафика. Уязвимости в диссекторах DCT3, LDAP и SMB, а также в коде для выполнения грамматического разбора файлов pcag-ng могут приводить к отказу в обслуживании или выполнению произвольного кода.

В предыдущем стабильном выпуске (lenny) эта проблема была исправлена в версии 1.0.2-3+lenny13.

В стабильном выпуске (squeeze) эта проблема была исправлена в версии 1.2.11-6+squeeze1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1.4.4-1.

Рекомендуется обновить пакеты wireshark.