Debian Security Advisory

DSA-2223-1 doctrine -- SQL injection

Date Reported:
20 Apr 2011
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 622674.
In Mitre's CVE dictionary: CVE-2011-1522.
More information:

It was discovered that Doctrine, a PHP library for implementing object persistence, contains SQL injection vulnerabilities. The exact impact depends on the application which uses the Doctrine library.

For the stable distribution (squeeze), this problem has been fixed in version 1.2.2-2+squeeze1.

We recommend that you upgrade your doctrine packages.