Debian セキュリティ勧告

DSA-2247-1 rails -- 複数の脆弱性

報告日時:
2011-05-31
影響を受けるパッケージ:
rails
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 614864.
Mitre の CVE 辞書: CVE-2011-0446, CVE-2011-0447.
詳細:

Ruby ウェブアプリケーションフレームワーク Rails に、複数の問題が発見さ れました。 The Common Vulnerabilities and Exposures project は以下の問 題を認識しています。

  • CVE-2011-0446

    JavaScript エンコーディング有効時に複数のクロスサイトスクリプティ JavaScript エンコーディング有効時に複数のクロスサイトスクリプティ ングを許す欠陥があるため、リモートの攻撃者が任意のウェブスクリプト や HTML を挿入可能です。

  • CVE-2011-0447

    Rails が X-Requested-With ヘッダを含む HTTP リクエストを適切に検 証していないため、リモートの攻撃者からのクロスサイトリクエストフ ォージェリ (CSRF) 攻撃が容易になっています。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は バージョン 2.1.0-7+lenny0.1 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 2.3.5-1.2+squeeze0.1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 2.3.11-0.1 で修正されています。

直ぐに rails パッケージをアップグレードすることを勧めます。