Debians sikkerhedsbulletin

DSA-2255-1 libxml2 -- bufferoverløb

Rapporteret den:
6. jun 2011
Berørte pakker:
libxml2
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 628537.
Yderligere oplysninger:

Chris Evans opdagede at libxml var sårbar over for bufferoverløb, hvilket gjorde det muligt, ved hjælp af en fabrikeret XML-inddatafil, potentielt at udføre vilkårlig kode.

I den gamle stabile distribution (lenny), er dette problem rettet i version 2.6.32.dfsg-5+lenny4.

I den stabile distribution (squeeze), er dette problem rettet i version 2.7.8.dfsg-2+squeeze1.

I den ustabile distribution (sid), er dette problem rettet i version 2.7.8.dfsg-3.

Vi anbefaler at du opgraderer dine libxml2-pakker.