Debian セキュリティ勧告

DSA-2255-1 libxml2 -- バッファオーバフロー

報告日時:
2011-06-06
影響を受けるパッケージ:
libxml2
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 628537.
詳細:

Chris Evans さんにより、libxml にバッファオーバフローを起こす欠陥があ り、細工した XML 入力ファイルにより任意のコードの実行の可能性があるこ とが発見されました。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は バージョン 2.6.32.dfsg-5+lenny4 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 2.7.8.dfsg-2+squeeze1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 2.7.8.dfsg-3 で修正されています。

直ぐに libxml2 パッケージをアップグレードすることを勧めます。