Debian セキュリティ勧告

DSA-2257-1 vlc -- ヒープベースのバッファオーバフロー

報告日時:
2011-06-10
影響を受けるパッケージ:
vlc
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-2194.
詳細:

Rocco Calvi さんにより、マルチメディアプレーヤ/ストリーマ vlc の XSPF プレイリストパーザに整数オーバフローがあり、ヒープベースのバッファオ ーバフローを引き起こすことが発見されました。この欠陥は細工したファイ ルを犠牲者に開かせることで攻撃可能で、任意のコードの実行を許す可能性 があります。

旧安定版 (lenny) にはこの問題の影響はありません。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1.1.3-1squeeze6 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューションで は、この問題は近く修正予定です。

直ぐに vlc パッケージをアップグレードすることを勧めます。