Debian セキュリティ勧告

DSA-2261-1 redmine -- 複数の脆弱性

報告日時:
2011-06-15
影響を受けるパッケージ:
redmine
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 608397.
詳細:

Phenoelit の Joernchen さんにより、プロジェクト管理向けウェブアプリケ ーションの Redmine に複数の欠陥が発見されました。

  • ログイン済みのユーザが個人の情報にアクセス可能です。
  • Textile フォーマッタでクロスサイトスクリプティング攻撃が可能なため、 攻撃者に機密情報が漏洩します。
  • The Bazaar リポジトリアダプタにより、リモートから Redmine を実行中の ホストで任意のコマンドを実行可能です。

旧安定版 (lenny) には redmine パッケージは収録されていません。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1.0.1-2 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューション では、この問題はバージョン 1.0.5-1 で修正されています。

直ぐに redmine パッケージをアップグレードすることを勧めます。