Bulletin d'alerte Debian

DSA-2268-1 iceweasel -- Plusieurs vulnérabilités

Date du rapport :
1er juillet 2011
Paquets concernés :
iceweasel
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2011-0083, CVE-2011-0085, CVE-2011-2362, CVE-2011-2363, CVE-2011-2365, CVE-2011-2371, CVE-2011-2373, CVE-2011-2374, CVE-2011-2376.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Iceweasel, un navigateur web basé sur Firefox :

  • CVE-2011-0083 et CVE-2011-2363

    regenrecht a découvert deux utilisations de mémoire après libération dans le traitement de SVG. Cela pourrait permettre l'exécution de code arbitraire.

  • CVE-2011-0085

    regenrecht a découvert une utilisation de mémoire après libération dans le traitement de XUL. Cela pourrait permettre l'exécution de code arbitraire.

  • CVE-2011-2362

    David Chan a découvert que les cookies n'étaient pas suffisamment isolés.

  • CVE-2011-2371

    Chris Rohlf et Yan Ivnitskiy ont découvert un débordement d'entier dans le moteur JavaScript. Cela pourrait permettre l'exécution de code arbitraire.

  • CVE-2011-2373

    Martin Barbella a découvert une utilisation de mémoire après libération dans le traitement de XUL. Cela pourrait permettre l'exécution de code arbitraire.

  • CVE-2011-2374

    Bob Clary, Kevin Brosnan, Nils, Gary Kwong, Jesse Ruderman et Christian Biesinger ont découvert des bogues de corruption de mémoire. Cela peut permettre l'exécution de code arbitraire.

  • CVE-2011-2376

    Luke Wagner et Gary Kwong ont découvert des bogues de corruption de mémoire. Cela peut permettre l'exécution de code arbitraire.

Pour la distribution oldstable (Lenny), ce problème a été corrigé dans la version 1.9.0.19-12 du paquet source xulrunner.

Pour la distribution stable (Squeeze), ce problème a été corrigé dans la version 3.5.16-8.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 3.5.19-3.

Pour la distribution experimental, ce problème a été corrigé dans la version 5.0-1.

Nous vous recommandons de mettre à jour vos paquets iceweasel.