Debian Security Advisory

DSA-2282-1 qemu-kvm -- several vulnerabilities

Date Reported:
25 Jul 2011
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2011-2212, CVE-2011-2527.
More information:

Two vulnerabilities have been discovered in KVM, a solution for full virtualization on x86 hardware:

  • CVE-2011-2212

    Nelson Elhage discovered a buffer overflow in the virtio subsystem, which could lead to denial of service or privilege escalation.

  • CVE-2011-2527

    Andrew Griffiths discovered that group privileges were insufficiently dropped when started with -runas option, resulting in privilege escalation.

For the stable distribution (squeeze), this problem has been fixed in version 0.12.5+dfsg-5+squeeze6.

For the unstable distribution (sid), this problem has been fixed in version 0.14.1+dfsg-3.

We recommend that you upgrade your qemu-kvm packages.