Debian Security Advisory

DSA-2283-1 krb5-appl -- programming error

Date Reported:
25 Jul 2011
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2011-1526.
More information:

Tim Zingelmann discovered that due an incorrect configure script the kerborised FTP server failed to set the effective GID correctly, resulting in privilege escalation.

The oldstable distribution (lenny) is not affected.

For the stable distribution (squeeze), this problem has been fixed in version 1.0.1-1.1.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your krb5-appl packages.