Debians sikkerhedsbulletin

DSA-2323-1 radvd -- flere sårbarheder

Rapporteret den:
26. okt 2011
Berørte pakker:
radvd
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 644614.
I Mitres CVE-ordbog: CVE-2011-3602, CVE-2011-3604, CVE-2011-3605.
Yderligere oplysninger:

Flere sikkerhedsproblemer blev opdaget af Vasiliy Kulikov i radvd, en IPv6 Router Advertisement-dæmon:

  • CVE-2011-3602

    Funktionen set_interface_var() kontrollerede ikke interfaccenavnet, som vælges af en upriviligeret bruger. Det kunne være til overskrivelse af en vilkårlig fil, hvis angriberen har adgang lokalt, og ellers specifikke overskrivelser af filer.

  • CVE-2011-3604

    Funktionen process_ra() manglede flere kontroller på bufferlængder, hvilket kunne føre til læsningen af hukommelse uden for stakken, forårsagende et crash af dæmonen.

  • CVE-2011-3605

    Funktionen process_rs() kalder mdelay() (en funktion, der venter i et specifikt tidsrum) betingelsesløst, når den kører i kun-unicast-tilstand. Da kaldet opsættes i hovedtråden, betyder det at al forespørgselsbehandling forsinkes (i tidsrum op til MAX_RA_DELAY_TIME, 500 ms som standard). En angriber kunne overstrømme dæmonen med router-forespørgsler, med det formål at fylde inddatakøen op, forårsagende et midlertidigt lammelsesangreb (behandlingen stoppede under alle mdelay()-kaldene).
    Bemærk: Opstrøm og Debian har anycast-tilstand aktiveret som standard.

I den gamle stabile distribution (lenny), er dette problem rettet i version 1:1.1-3.1.

I den stabile distribution (squeeze), er dette problem rettet i version 1:1.6-1.1.

I distributionen testing (wheezy), er dette problem rettet i version 1:1.8-1.2.

I den ustabile distribution (sid), er dette problem rettet i version 1:1.8-1.2.

Vi anbefaler at du opgraderer dine radvd-pakker.