Debian セキュリティ勧告

DSA-2367-1 asterisk -- 複数の脆弱性

報告日時:
2011-12-19
影響を受けるパッケージ:
asterisk
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-4597, CVE-2011-4598.
詳細:

オープンソース交換機・IP 電話ツールキット asterisk に、複数の問題が発 見されました。

  • CVE-2011-4597

    Ben Williams さんにより、特定の設定下で SIP ユーザ名の数を知ること ができることが発見されました。詳細は、 上流の勧告をご覧くださ い。

    この更新では、sip.conf 設定ファイルのサンプル例を更新しているだけ です。インストールされた asterisk を更新する方法については README.Debian を参照ください。

  • CVE-2011-4598

    Kristijan Vrban さんにより、automon 機能が有効化されている場合、 Asterisk を不正な SIP パケットでクラッシュさせることが可能であるこ とが発見されました。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は バージョン 1:1.4.21.2~dfsg-3+lenny6 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1:1.6.2.9-2+squeeze4 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 1:1.8.8.0~dfsg-1 で修正されています。

直ぐに asterisk パッケージをアップグレードすることを勧めます。