Debian Security Advisory

DSA-2371-1 jasper -- buffer overflows

Date Reported:
24 Dec 2011
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2011-4516, CVE-2011-4517.
More information:

Two buffer overflows were discovered in JasPer, a library for handling JPEG-2000 images, which could lead to the execution of arbitrary code.

For the oldstable distribution (lenny), this problem will be fixed in version 1.900.1-5.1+lenny2. Due to technical limitations of the Debian archive software, the oldstable update cannot be released synchronously with the stable update.

For the stable distribution (squeeze), this problem has been fixed in version 1.900.1-7+squeeze1.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your jasper packages.