Debian セキュリティ勧告

DSA-2380-1 foomatic-filters -- シェルコマンドインジェクション

報告日時:
2012-01-04
影響を受けるパッケージ:
foomatic-filters
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 635549.
Mitre の CVE 辞書: CVE-2011-2697, CVE-2011-2964.
詳細:

プリンタの設定を支援するパッケージ foomatic-filters に、欠陥が発見さ れました。認証済みユーザが細工したプリンタジョブを投入することにより、 プリントサーバ上でのシェルコマンドの実行を許します。

lenny ではこの欠陥の部位は Perl で実装されており、 CVE-2011-2697 が割り当てられています。squeeze ではこの処理は C で再実装されており、 CVE-2011-2964 が割り当てられています。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は バージョン 3.0.2-20080211-3.2+lenny1 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 4.0.5-6+squeeze1 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューション では、この問題はバージョン 4.0.9-1 で修正されています。

直ぐに foomatic-filters パッケージをアップグレードすることを勧めます。