Рекомендация Debian по безопасности

DSA-2380-1 foomatic-filters -- инъекция команды командной оболочки

Дата сообщения:
04.01.2012
Затронутые пакеты:
foomatic-filters
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 635549.
В каталоге Mitre CVE: CVE-2011-2697, CVE-2011-2964.
Более подробная информация:

Было обнаружено, что foomatic-filters, пакет поддержки для настройки принтеров, позволяет аутентифицированным пользователя отправлять специально сформированные задания печати, которые приводят к выполнению команд командной оболочки на серверах печати.

Идентификатор CVE-2011-2697 был присвоен этой уязвимости, содержащейся в реализации на языке Perl, которая имеется в lenny, а идентификатор CVE-2011-2964 был присвоен этой уязвимости, содержащейся в реализации на языке C, которая имеется в squeeze.

В предыдущем стабильном выпуске (lenny) эта проблема была исправлена в версии 3.0.2-20080211-3.2+lenny1.

В стабильном выпуске (squeeze) эта проблема была исправлена в версии 4.0.5-6+squeeze1.

В тестируемом (wheezy) и нестабильном (sid) выпусках эта проблема была исправлена в версии 4.0.9-1.

Рекомендуется обновить пакеты foomatic-filters.