Debian セキュリティ勧告

DSA-2391-1 phpmyadmin -- 複数の脆弱性

報告日時:
2012-01-22
影響を受けるパッケージ:
phpmyadmin
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 656247.
Mitre の CVE 辞書: CVE-2011-1940, CVE-2011-3181, CVE-2011-4107.
詳細:

MySQL をウェブベースで管理するツール phpMyAdmin に、複数の問題が発見さ れました。 The Common Vulnerabilities and Exposures project は以下の問 題を認識しています。

  • CVE-2011-4107

    XML インポートプラグインは、リモートの攻撃者により、外部エンティティ 参照を含む XML により任意のファイルを読み込み可能です。

  • CVE-2011-1940, CVE-2011-3181 CVE-2011-1940, CVE-2011-3181

    テーブルトラッキング機能によりクロスサイトスクリプティング攻撃が可能 なため、リモートの攻撃者による任意のウェブスクリプト及び HTML の注入 を許します。

旧安定版 (lenny) にはこれらの問題の影響はありません。

安定版 (stable) ディストリビューション (squeeze) では、これらの問題は バージョン 4:3.3.7-7 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューションでは、 これらの問題はバージョン 4:3.4.7.1-1 で修正されています。

直ぐに phpmyadmin パッケージをアップグレードすることを勧めます。