Debian セキュリティ勧告

DSA-2410-1 libpng -- 整数オーバフロー

報告日時:
2012-02-15
影響を受けるパッケージ:
libpng
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-3026.
詳細:

Jueri Aedla さんにより、PNG ファイル用ライブラリ libpng に整数オーバ フローがあり、不正な形式の画像処理の際に任意のコードの実行に繋がる可 能性があることが発見されました。 直ぐに libpng パッケージをアップグレードすることを勧めます。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1.2.44-1+squeeze2 で修正されています。 直ぐに libpng パッケージをアップグレードすることを勧めます。

不安定版 (unstable) ディストリビューション (sid) では、この問題は近 く修正予定です。 直ぐに libpng パッケージをアップグレードすることを勧めます。

直ぐに libpng パッケージをアップグレードすることを勧めます。