Bulletin d'alerte Debian

DSA-2423-1 movabletype-opensource -- Plusieurs vulnérabilités

Date du rapport :
2 mars 2012
Paquets concernés :
movabletype-opensource
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 631437, Bogue 661064.
Dans le dictionnaire CVE du Mitre : CVE-2012-1497, CVE-2012-1262, CVE-2012-0320, CVE-2012-0319, CVE-2012-0318, CVE-2012-0317, CVE-2011-5085, CVE-2011-5084.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Movable Type, un moteur de blog.

Dans certaines circonstances, un utilisateur ayant le droit de Création d'une note ou de Gérer un blog pourrait réussir à lire des fichiers connus sur le système de fichiers local.

Le système de gestion de fichiers contient des vulnérabilités d'injection de commandes d'interpréteur, la plus sérieuse pouvant permettre à un utilisateur, ayant le droit de s'inscrire au script d'administration et d'envoyer des fichiers, d'exécuter des commandes arbitraires de système d'exploitation.

Des vulnérabilités de détournement de session et de contrefaçon de requête intersite existent dans les scripts de commentaire et de communauté. Un attaquant distant pourrait détourner la session d'un utilisateur ou exécuter du code de script arbitraire sur le navigateur de la victime dans certaines circonstances.

Les gabarits qui ne protègent pas correctement les variables et mt-wizard.cgi contiennent des vulnérabilités de script intersite.

Pour la distribution stable (Squeeze), ces problèmes ont été corrigés dans la version 4.3.8+dfsg-0+squeeze2.

Pour la distribution testing (Wheezy) et la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 5.1.3+dfsg-1.

Nous vous recommandons de mettre à jour vos paquets movabletype-opensource.