Debians sikkerhedsbulletin

DSA-2432-1 libyaml-libyaml-perl -- formatstrengssårbarheder

Rapporteret den:
12. mar 2012
Berørte pakker:
libyaml-libyaml-perl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 661548.
I Mitres CVE-ordbog: CVE-2012-1152.
Yderligere oplysninger:

Dominic Hargreaves og Niko Tyni opdagede to formatstrengssårbarheder i YAML::LibYAML, en Perl-grænseflade til libyaml-biblioteket.

I den stabile distribution (squeeze), er dette problem rettet i version 0.33-1+squeeze1.

I den ustabile distribution (sid), er dette problem rettet i version 0.38-2.

Vi anbefaler at du opgraderer dine libyaml-libyaml-perl-pakker.