Debian セキュリティ勧告

DSA-2432-1 libyaml-libyaml-perl -- フォーマット文字列バグ

報告日時:
2012-03-12
影響を受けるパッケージ:
libyaml-libyaml-perl
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 661548.
Mitre の CVE 辞書: CVE-2012-1152.
詳細:

Dominic Hargreaves さんと Niko Tyni さんにより、libyaml ライブラリの Perl インターフェース TAML::libYAML に二つのフォーマット文字列バグが 発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 0.33-1+squeeze1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 0.38-2 で修正されています。

直ぐに libyaml-libyaml-perl パッケージをアップグレードすることを勧め ます。