Debian Security Advisory

DSA-2436-1 libapache2-mod-fcgid -- inactive resource limits

Date Reported:
19 Mar 2012
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 615814.
In Mitre's CVE dictionary: CVE-2012-1181.
More information:

It was discovered that the Apache FCGID module, a FastCGI implementation, did not properly enforce the FcgidMaxProcessesPerClass resource limit, rendering this control ineffective and potentially allowing a virtual host to consume excessive resources.

For the stable distribution (squeeze), this problem has been fixed in version 1:2.3.6-1+squeeze1.

For the testing distribution (wheezy), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in version 1:2.3.6-1.1.

We recommend that you upgrade your libapache2-mod-fcgid packages.