Debian セキュリティ勧告

DSA-2439-1 libpng -- バッファオーバフロー

報告日時:
2012-03-22
影響を受けるパッケージ:
libpng
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-3045.
詳細:

Glenn-Randers Pehrson さんにより、libpng PNG ライブラリにバッファオー バフローがあり、不正な形式の画像処理で任意のコードの実行が可能である ことが発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1.2.44-1+squeeze3 で修正されています。i386 向けのパッケージは まだ提供されていませんが、近く提供の予定です。

不安定版 (unstable) ディストリビューション (sid) では、この問題は近 く修正予定です。

直ぐに libpng パッケージをアップグレードすることを勧めます。