Debians sikkerhedsbulletin

DSA-2445-1 typo3-src -- flere sårbarheder

Rapporteret den:
31. mar 2012
Berørte pakker:
typo3-src
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-1606, CVE-2012-1607, CVE-2012-1608.
Yderligere oplysninger:

Flere fjernudnytbare sårbarheder er opdaget i TYPO3, et framework til håndtering af webindhold:

  • CVE-2012-1606

    Manglende korrekt HTML-indkapsling af brugerleverede data flere steder, gjorde TYPO3-backend'en sårbar over for udførelse af skripter på tværs af websteder. En gyldig backendbruger er krævet for at udnytte disse sårbarheder.

  • CVE-2012-1607

    Tilgang til et CLI-skript direkte fra browseren, kunne måske blotlægge det databasenavn, som TYPO3-installationen anvender.

  • CVE-2012-1608

    Ved ikke at fjerne ikke-skrivbare tegn, lykkedes det ikke for API-metoden t3lib_div::RemoveXSS() at bortfiltrere særligt fremstillede HTML-indsprøjtninger, og dermed var den sårbar over for udførelse af skripter på tværs af websteder.

I den stabile distribution (squeeze), er disse problemer rettet i version 4.3.9+dfsg1-1+squeeze3.

I distributionen testing (wheezy) og i den ustabile distribution (sid), er disse problemer rettet i version 4.5.14+dfsg1-1.

Vi anbefaler at du opgraderer dine typo3-src-pakker.