Debian セキュリティ勧告

DSA-2462-2 imagemagick -- 複数の脆弱性

報告日時:
2012-05-03
影響を受けるパッケージ:
imagemagick
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2012-0259, CVE-2012-0260, CVE-2012-1185, CVE-2012-1186, CVE-2012-1610, CVE-2012-1798.
詳細:

任意のコードの実行やサービス拒否攻撃に繋がる複数の整数オーバフローや入力の検証漏れが、 画像操作プログラム群 ImageMagick に発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 6.6.0.4-3+squeeze3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 8:6.7.4.0-5 で修正されています。

直ぐに imagemagick パッケージをアップグレードすることを勧めます。