Debian セキュリティ勧告

DSA-2466-1 rails -- クロスサイトスクリプティング

報告日時:
2012-05-09
影響を受けるパッケージ:
rails
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 668607.
Mitre の CVE 辞書: CVE-2012-1099.
詳細:

Sergey Nartimov さんにより、ウェブ開発向け Ruby ベースのフレームワー ク Rails が、開発者が手動で option タグを生成している場合に、この人 手作成のタグとユーザ入力を合成した入力が適切にエスケープされていない ため、攻撃者が任意の HTML 文を文書に注入できることが発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 2.3.5-1.2+squeeze3 で修正されています。

テスト版 (wheezy) および不安定版 (unstable) ディストリビューションで は、この問題はバージョン 2.3.14 で修正されています。

直ぐに rails パッケージをアップグレードすることを勧めます。