Debians sikkerhedsbulletin

DSA-2473-1 openoffice.org -- bufferoverløb

Rapporteret den:
16. maj 2012
Berørte pakker:
openoffice.org
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-1149.
Yderligere oplysninger:

Tielei Wang opdagede, at OpenOffice.org ikke allokerer et hukommelsesområde, som er stort nok, når der behandles særligt fremstillede JPEG-objekter, førende til et heap-baseret bufferoverløb og potentielt udførelse af vilkårlig kode.

I den stabile distribution (squeeze), er dette problem rettet i version 1:3.2.1-11+squeeze5.

I distributionen testing (wheezy) og i den ustabile distribution (sid), er dette problem rettet i version 1:3.4.5-1 af pakken libreoffice.

Vi anbefaler at du opgraderer dine openoffice.org-pakker.