Debians sikkerhedsbulletin

DSA-2475-1 openssl -- heltalsunderløb

Rapporteret den:
17. maj 2012
Berørte pakker:
openssl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-2333.
Yderligere oplysninger:

Man opdagede, at openssl ikke på korrekt vis håndterede eksplicitte Initialization Vectors til CBC-krypteringstilstande, som anvendes i TLS 1.1, 1.2 og DTLS. En ukorrekt beregning ville føre til en heltalsunderløb og ukorrekt hukommelsestilgang, forårsagende et lammelsesangreb (applikationsnedbrud).

I den stabile distribution (squeeze), er dette problem rettet i version 0.9.8o-4squeeze13.

I distributionen testing (wheezy) og i den ustabile distribution (sid), er dette problem rettet i version 1.0.1c-1.

Vi anbefaler at du opgraderer dine openssl-pakker.