Bulletin d'alerte Debian

DSA-2478-1 sudo -- Erreur de traitement

Date du rapport :
23 mai 2012
Paquets concernés :
sudo
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2012-2337.
Plus de précisions :

sudo traitait mal les masques réseau utilisés dans les morceaux Host et Host_List. Cela permettait l'exécution de commandes sur les hôtes où l'utilisateur ne serait pas autorisé à lancer ces commandes.

Pour la distribution stable (Squeeze), ce problème a été corrigé dans la version 1.7.4p4-2.squeeze.3.

Pour la distribution unstable (Sid), ce problème sera corrigé prochainement.

Nous vous recommandons de mettre à jour vos paquets sudo.