Рекомендация Debian по безопасности

DSA-2482-1 libgdata -- недостаточная проверка сертификатов

Дата сообщения:
02.06.2012
Затронутые пакеты:
libgdata
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 664032.
В каталоге Mitre CVE: CVE-2012-1177.
Более подробная информация:

Врейксо Формозо обнаружил, что libgdata, библиотека, используемая для обращения к различным сервисам Google, при использовании соединения по протоколу HTTPS не выполняет проверку сертификатов и сравнение с сертификатами доверенных корневых авторитетов.

В стабильном выпуске (squeeze) эта проблема была исправлена в версии 0.6.4-2+squeeze1.

В тестируемом выпуске (wheezy) эта проблема была исправлена в версии 0.10.2-1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 0.10.2-1.

Рекомендуется обновить пакеты libgdata.