Bulletin d'alerte Debian

DSA-2496-1 mysql-5.1 -- Plusieurs vulnérabilités

Date du rapport :
18 juin 2012
Paquets concernés :
mysql-5.1
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 670636, Bogue 677018.
Dans le dictionnaire CVE du Mitre : CVE-2012-0540, CVE-2012-0583, CVE-2012-1688, CVE-2012-1689, CVE-2012-1690, CVE-2012-1703, CVE-2012-1734, CVE-2012-2102, CVE-2012-2122, CVE-2012-2749.
Plus de précisions :

À cause de la non divulgation des renseignements sur les correctifs de sécurité de la part d'Oracle, nous sommes forcés d'embarquer une mise à jour de version amont de MySQL 5.1. Plusieurs modifications incompatibles connues sont énumérées dans /usr/share/doc/mysql-server/NEWS.Debian.gz.

Plusieurs vulnérabilités de sécurité ont été découvertes dans MySQL, un système de gestion de bases de données. Les vulnérabilités sont réglées en mettant à niveau MySQL vers une nouvelle version amont, 5.1.63, qui contient des modifications supplémentaires, comme des améliorations de performance et des corrections aux défauts de pertes de données. Ces modifications sont décrites dans les notes de publications de MySQL.

CVE-2012-2122, une vulnérabilité de contournement d'authentification, n'arrive que si MySQL a été construit avec certaines optimisations activées. Les paquets de Debian stable (Squeeze) ne sont a priori pas concernés par cette vulnérabilité. Elle est tout de même corrigée dans cette mise à jour, pour que les prochaines reconstructions ne deviennent pas vulnérables à ce problème.

Pour la distribution stable (Squeeze), ces problèmes ont été corrigés dans la version 5.1.63-0+squeeze1.

Pour la distribution testing (Wheezy), ces problèmes ont été corrigés dans la version 5.1.62-1 du paquet mysql-5.1 et la version 5.5.24+dfsg-1 du paquet mysql-5.5.

Nous vous recommandons de mettre à jour vos paquets MySQL.