Рекомендация Debian по безопасности

DSA-2501-1 xen -- несколько уязвимостей

Дата сообщения:
24.06.2012
Затронутые пакеты:
xen
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2012-0217, CVE-2012-0218, CVE-2012-2934.
Более подробная информация:

В гипервизоре Xen было обнаружено несколько уязвимостей.

  • CVE-2012-0217

    Xen неправильно обрабатывает неканонические возвращаемые адреса на ЦП Intel amd64, позволяя гостевым PV-системам amd64 повышать привилегии до уровня гипервизора. Процессоры AMD, гостевые системы HVM и i386 не подвержены данной уязвимости.

  • CVE-2012-0218

    Xen неправильно обрабатывает инструкции SYSCALL и SYSENTER в гостевых PV-системах, позволяя непривилегированным пользователям, находящимися в гостевой системе, вызывать аварийную остановку гостевой системы.

  • CVE-2012-2934

    Xen не определяет старые ЦП AMD, подверженные AMD Erratum #121.

При ошибке CVE-2012-2934 Xen отказывается запускать domU, пока не будет передана опция allow_unsafe.

В стабильном выпуске (squeeze) эти проблемы были исправлены в версии 4.0.1-5.2.

В тестируемом (wheezy) и нестабильном (sid) выпусках эти проблемы были исправлены в версии 4.1.3~rc1+hg-20120614.a9c0a89c08f2-1.

Рекомендуется обновить пакеты xen.