Debians sikkerhedsbulletin

DSA-2509-1 pidgin -- fjernudførelse af kode

Rapporteret den:
8. jul 2012
Berørte pakker:
pidgin
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-3374.
Yderligere oplysninger:

Ulf Härnhammar fandt et bufferoverløb i Pidgin, et chatprogram som understøtter flere protokoller. Sårbarheden kunne udnyttes af en indgående meddelelse i MXit-protokolplugin'en. En fjernangriber kunne måske forårsage et nedbrud, og under nogle omstændigheder fjernudføre kode.

I den stabile distribution (squeeze), er dette problem rettet i version 2.7.3-1+squeeze3.

I distributionen testing (wheezy), er dette problem rettet i version 2.10.6-1.

I den ustabile distribution (sid), er dette problem rettet i version 2.10.6-1.

Vi anbefaler at du opgraderer dine pidgin-pakker.